This article describes how to migrate shares from ReadyDATA to ReadyNAS.
Note: When the shares have been migrated to ReadyNAS, it will be necessary to manually re-configure permissions as required.
In this example, the following share exists on the ReadyDATA:

Here, we migrate the share called DeptShare. The process can be repeated for all other shares.
- Go to the ReadyDATA admin page.
- Select Shares.
- Right click on the share and choose Properties:

- Ensure that Allow Snapshot Access is disabled:

Disabling Allow Snapshot Access is recommended because if there are snapshots on the share, enabling this option creates a snapshot folder in the share. Inside this snapshot folder, there will exist a full copy of the share for each snapshot. During the migration, the copy process will traverse each snapshot folder and copy the full contents of each snapshot. This can result in an exponentially large amount of data being copied to the destination. - Ensure that SMB access is enabled on the share:

- Go to the ReadyNAS admin page.
- Go to the Shares tab.
- Click New Share:

- Enter a name for the share, set other options as required and click Create:

- Go to the Backup tab and click Add Backup:

- Enter a name for the backup job:

- In the left side of the backup configuration settings, click Remote.
- In the Host field, enter the hostname or IP address of the ReadyDATA.
- In the Protocol field, choose remote: Windows/NAS (Timestamp).
- In the Share field, enter the name of the share on the ReadyDATA.
- In the Login and Password field, enter the admin username and password for the ReadyDATA.
- Click Test Connection to verify that the settings are valid.

- In the right side of the backup configuration settings, click Local, and then click Browse:

- Navigate through the directory structure of the ReadyNAS and select the share that you want to back up to. Then click Select:

- Click Next.
- At the next screen, untick Enable Schedule and click Finish. We do not use a schedule because this is a one time backup.

- Right click on the backup job and click Start:

The status column of the job changes to In Progress and the data is copied from the ReadyDATA share to the ReadyNAS share.
Allow sufficient time for the job to complete. When the job is successful, the status changes to Completed. If there are problems during the copy, the status changes to Failed. In the case of a failed copy, right click the job and click Log to view the reason for the failure.