The following are the firmware release notes from 6.0.1 (January 2013) up to 6.3.5 (July 2015).
The notes are also embedded in the download ZIP file. ReadyNAS-OS6 product page
Applicable network attached storage products are
- ReadyNAS 102
- ReadyNAS 104
- ReadyNAS 202
- ReadyNAS 204
- ReadyNAS 312
- ReadyNAS 314
- ReadyNAS 316
- ReadyNAS 516
- ReadyNAS 716
- ReadyNAS 2120
- ReadyNAS 3130
- ReadyNAS 3220
- ReadyNAS 4220
ReadyNAS OS 6.3.5 (RN200 Only) Release Notes: (July 2015)
Enhancements & Bug Fixes:
- Updated the Linux Kernel which includes btrfs, iSCSI and NFS enhancements.
- Fixed UI crash on systems with a large number (80+) of DLNA-enabled shares.
- Fixed user interface issue when creating a backup job to a USB device.
- Improved LACP link aggregation performance for 200 series.
ReadyNAS OS 6.2.5 (RN100 Only) Release Notes: (July 2015)
Enhancements & Bug Fixes:
- Adjusted CPU and memory timing to improve system stability on RN10x models.
- Fixed UI crash on systems with a large number (80+) of DLNA-enabled shares.
- Fixed user interface issue when creating a backup job to a USB device.
ReadyNAS OS 6.3.4 (RN200 Only) Release Notes: (April 2015)
Enhancements & Bug Fixes:
- Fixes the issue with firmware update 6.2.3/6.3.3 that can make the NAS inaccessible when used in an Active Directory/Domain setup with duplicate group names.
- Fixes the issue with iSCSI that sometimes it does not reconnect automatically after reboot or network disconnection.
- Fixes the issue with Active Directory username that has multiple words with spaces in it.
- Fixes the issue that Mac cannot find Time Machine backup disk after upgrading from 6.2.2/6.3.2 to 6.2.3/6.3.3.
- Reports app upgrade failure properly, previously it only reports error if it is a first-time install.
ReadyNAS OS 6.2.4 Release Notes: (April 2015)
Enhancements & Bug Fixes:
- Fixes the issue with firmware update 6.2.3/6.3.3 that can make the NAS inaccessible when used in an Active Directory/Domain setup with duplicate group names.
- Fixes the issue with iSCSI that sometimes it does not reconnect automatically after reboot or network disconnection.
- Fixes the issue with Active Directory username that has multiple words with spaces in it.
- Fixes the issue that Mac cannot find Time Machine backup disk after upgrading from 6.2.2/6.3.2 to 6.2.3/6.3.3.
- Reports app upgrade failure properly, previously it only reports error if it is a first-time install.
Deployment Notes / Limitations:
- Wake on LAN (WOL) will not be supported on the ReadyNAS 4220 at this time using the 10GbE port. Use the 1GbE port for WOL.
- There is no error message presented in the local admin GUI when the USB key is missing from the system for encrypted volumes. The LCD display will present a message that the USB key is missing.
- If the USB key is missing for encrypted volumes, the user has to wait for a 10 minute timeout. After the timeout, the encrypted volume will appear as inactive in the local admin GUI.
- If a FLEX-RAID volume has be expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should first eject the drive in the local admin GUI before removing the USB device from the ReadyNAS to prevent errors on the file system of the USB device.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 102, 104, and 2120 only support volumes up to 16TB.
- ReadyNAS devices updated to ReadyNAS 6.2.0 or later cannot be downgraded to ReadyNAS 6.1.x or earlier.
ReadyNAS OS 6.3.3 (RN200 Only) Release Notes: (April 2015)
Enhancements & Bug Fixes:
- Fixed issue where removing certain apps would bring the web interface offline.
- Lower SMB allocation roundup size, so Windows 8.1 shows reasonable Disk Used values.
- Fixed incorrect default Gmail alert settings.
- Kernel security updates and various bug fixes.
- Revert higher fan RPMs with Seagate disks.
- Fixed potential system hang with Anti-Virus enabled.
- Fixed potential system hang on 4-bay units with disk spindown enabled.
- Suppress duplicate anti-virus warnings.
- Does not send email alerts about virus definition updates.
- Prevent SNMP connections from spamming the system logs.
- Fixed premature snipping of logs when downloading log .zip file.
- Don't try to spin down SSDs.
- Fixed snapshot access via "Previous Versions" in Windows on shares with multi-byte characters in the share name.
- Fixed downloading files from USB drives through ReadyCLOUD.
- Various upstream security updates.
- Fixed NFS discovery issue with Kodi / XBMC.
- Fixed SMB discovery issue when the NAS is operating as the NETBIOS master browser.
- Enhances system log download contents.
- Fixed iTunes 12.1 incompatibility.
- Increased max ADS connections, to gracefully handle very busy AD environments.
- Improve volume information sent to RAIDar client.
- Added HTTP server "safe mode" fallback in case of misconfiguration.
- Scheduler change to hopefully resolve random freezing on RN10x.
- Fixed exposing of visible snapshots in some cases.
- Upstream security fixes.
- More changes for RN104 hang.
- Improve UI auto-reconnect mechanism.
- Better handling of joining very strict ADS environments.
- System timer tweaks for RN10x.
- Patched CVE-2015-0240.
- Fixed GUI crash when there was an inactive volume present.
- Disabled perf events in ARM kernel.
- Improved information gathered for log zip file.
- Fixed memory leak in LLMNR responder.
- Fixed out-of-memory condition in iTunes server caused by large zero-filled files.
- Reserve more system memory on busy systems, to page allocation failures.
- Fixed downgrades to 6.2.2.
- Filter out duplicate bit rot events.
- Fixed false VCore voltage alerts from RN3130.
- Changed I/O scheduler on RN10x.
- Fixed NFS thread count setting being overwritten on update.
- Fixed bad DVBLink interaction with RNx16 buttons.
- Fixed overly picky path input validation when creating backup jobs.
- Don't fail to start management daemon when encountering an unsupported UPS.
- Added a confirmation dialog when removing apps.
- Fixed UI connection repair mechanism with certain browsers on HTTPS connections.
- Disabled x86 kernel memory compaction support.
- Fixed SMB permissions breakage after changing NAS hostname.
- Latest OpenSSL security fixes.
- Added full ca-certificates bundle to fix apps that use HTTPS.
- Fixed possible CPU spinner bug after canceling an SMB transfer.
- Fixed IPv6 address display in UI.
- Fixed invalid scheduled disk test result reporting.
ReadyNAS OS 6.2.3 Release Notes: (April 2015)
Enhancements & Bug Fixes:
- Fixed issue where removing certain apps would bring the web interface offline.
- Lower SMB allocation roundup size, so Windows 8.1 shows reasonable Disk Used values.
- Fixed incorrect default Gmail alert settings.
- Kernel security updates and various bug fixes.
- Revert higher fan RPMs with Seagate disks.
- Fixed potential system hang with Anti-Virus enabled.
- Fixed potential system hang on 4-bay units with disk spindown enabled.
- Suppress duplicate anti-virus warnings.
- Does not send email alerts about virus definition updates.
- Prevent SNMP connections from spamming the system logs.
- Fixed premature snipping of logs when downloading log .zip file.
- Don't try to spin down SSDs.
- Fixed snapshot access via "Previous Versions" in Windows on shares with multi-byte characters in the share name.
- Fixed downloading files from USB drives through ReadyCLOUD.
- Various upstream security updates.
- Fixed NFS discovery issue with Kodi / XBMC.
- Fixed SMB discovery issue when the NAS is operating as the NETBIOS master browser.
- Enhances system log download contents.
- Fixed iTunes 12.1 incompatibility.
- Increased max ADS connections, to gracefully handle very busy AD environments.
- Improve volume information sent to RAIDar client.
- Added HTTP server "safe mode" fallback in case of misconfiguration.
- Scheduler change to hopefully resolve random freezing on RN10x.
- Fixed exposing of visible snapshots in some cases.
- Upstream security fixes.
- More changes for RN104 hang.
- Improve UI auto-reconnect mechanism.
- Better handling of joining very strict ADS environments.
- System timer tweaks for RN10x.
- Patched CVE-2015-0240.
- Fixed GUI crash when there was an inactive volume present.
- Disabled perf events in ARM kernel.
- Improved information gathered for log zip file.
- Fixed memory leak in LLMNR responder.
- Fixed out-of-memory condition in iTunes server caused by large zero-filled files.
- Reserve more system memory on busy systems, to page allocation failures.
- Fixed downgrades to 6.2.2.
- Filter out duplicate bit rot events.
- Fixed false VCore voltage alerts from RN3130.
- Changed I/O scheduler on RN10x.
- Fixed NFS thread count setting being overwritten on update.
- Fixed bad DVBLink interaction with RNx16 buttons.
- Fixed overly picky path input validation when creating backup jobs.
- Don't fail to start management daemon when encountering an unsupported UPS.
- Added a confirmation dialog when removing apps.
- Fixed UI connection repair mechanism with certain browsers on HTTPS connections.
- Disabled x86 kernel memory compaction support.
- Fixed SMB permissions breakage after changing NAS hostname.
- Latest OpenSSL security fixes.
- Added full ca-certificates bundle to fix apps that use HTTPS.
- Fixed possible CPU spinner bug after canceling an SMB transfer.
- Fixed IPv6 address display in UI.
- Fixed invalid scheduled disk test result reporting.
Deployment Notes / Limitations:
- Wake on LAN (WOL) will not be supported on the ReadyNAS 4220 at this time using the 10GbE port. Use the 1GbE port for WOL.
- There is no error message presented in the local admin GUI when the USB key is missing from the system for encrypted volumes. The LCD display will present a message that the USB key is missing.
- If the USB key is missing for encrypted volumes, the user has to wait for a 10 minute timeout. After the timeout, the encrypted volume will appear as inactive in the local admin GUI.
- If a FLEX-RAID volume has be expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should first eject the drive in the local admin GUI before removing the USB device from the ReadyNAS to prevent errors on the file system of the USB device.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 102, 104, and 2120 only support volumes up to 16TB.
- ReadyNAS devices updated to ReadyNAS 6.2.0 or later cannot be downgraded to ReadyNAS 6.1.x or earlier.
ReadyNAS OS 6.3.2 (RN200 only) Release Notes: (April 2015)
Enhancements & Bug Fixes:
- Added RN202 and RN204 to the hardware support list
- Fixed the issue where removing certain apps would bring the web interface offline
- Lower SMB allocation roundup size, so Windows 8.1 shows reasonable Disk Used values
- Fixed incorrect default Gmail alert settings
- Revert higher fan RPMs with Seagate disks
- Kernel upgrade to Linux 3.12.28
ReadyNAS OS 6.2.2 Release Notes: (December 2014)
Enhancements & Bug Fixes:
- Fixed LAN instability in some IPv6-enabled environments.
- Fixed FQDN validation for modifying existing backup jobs.
- Fixed potential dangling external storage lock, which could cause external drives to not mount.
- Fixed issue with expansion not completing.
Deployment Notes / Limitations:
- Wake on LAN (WOL) will not be supported on the ReadyNAS 4220 at this time using the 10GbE port. Use the 1GbE port for WOL.
- There is no error message presented in the local admin GUI when the USB key is missing from the system for encrypted volumes. The LCD display will present a message that the USB key is missing.
- If the USB key is missing for encrypted volumes, the user has to wait for a 10 minute timeout. After the timeout, the encrypted volume will appear as inactive in the local admin GUI.
- If a FLEX-RAID volume has be expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should first eject the drive in the local admin GUI before removing the USB device from the ReadyNAS to prevent errors on the file system of the USB device.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 102, 104, and 2120 only support volumes up to 16TB.
- ReadyNAS devices updated to ReadyNAS 6.2.0 or later cannot be downgraded to ReadyNAS 6.1.x or earlier.
ReadyNAS OS 6.2.1 Release Notes: (December 2014)
Enhancements & Bug Fixes:
- Fixes improper rejection of FQDNs in the backup job Host field.
- Fixes home shares not being visible on ReadyCLOUD client.
- Fixes ADS account imports on domains where an object has changed types.
- Cloud users will now use default TimeMachine settings for new accounts.
- Fixes app installation of apps whose package dependencies contain special characters.
- Revert the NETGEAR logo LED default state back to off on the RN316/516 front panel.
- Reduce pruning snapshots to a more balanced quantity when the volume is approaching full.
- Fixed CPU spinner bug during snapshot pruning when encountering full secondary volumes.
- Disable 3rd party web applications that conflict with the admin page UI.
- Provide a method for apps to configure global settings without breaking the admin web UI.
- Fixed a bug where app installation would never report failure.
- Fixes the configuration of offline network interfaces.
- Stamp alert emails with the date and time of the actual event, instead of when the alert is successfully sent.
- Removed redirect of non-admin failed accesses to the password recovery page after authentication failure.
- Skip EFI System Partitions when mounting external storage.
- Fixes certain snapshot-related operations not working in 6.2.0 in the GUI file browser.
- Fixes physical buttons not working on RN10x systems in 6.2.0.
- Added options to set the NFS thread count below 8.
- Fixes system hang issue on large SMB2/3 writes on RN2120 systems.
- Fixes file browser GUI context menus.
- Improves scalability in large ADS environments.
- Fixes potential false positives from Bit Rot Protection.
- Fixes occasional ReadyCLOUD invitation errors.
- Fixes admin access to volume root getting reset on update.
- Avoid out-of-space errors when doing a balance on very full filesystems.
- Disables sync mode by default for EXT3/4 external drives, to improve write performance.
- Properly clean up the file system after failure of 3rd party app installation.
-
Deployment Notes / Limitations:
- Wake on LAN (WOL) will not be supported on the ReadyNAS 4220 at this time using the 10GbE port. Use the 1GbE port for WOL.
- There is no error message presented in the local admin GUI when the USB key is missing from the system for encrypted volumes. The LCD display will present a message that the USB key is missing.
- If the USB key is missing for encrypted volumes, the user has to wait for a 10 minute timeout. After the timeout, the encrypted volume will appear as inactive in the local admin GUI.
- If a FLEX-RAID volume has be expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should first eject the drive in the local admin GUI before removing the USB device from the ReadyNAS to prevent errors on the file system of the USB device.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 102, 104, and 2120 only support volumes up to 16TB.
- ReadyNAS devices updated to ReadyNAS 6.2.0 or later cannot be downgraded to ReadyNAS 6.1.x or earlier.
ReadyNAS OS 6.2.0 Release Notes: (November 2014)
Enhancements & Bug Fixes:
- ReadyDROP has been replaced by a more granular syncing solution. PC clients using ReadyCLOUD desktop app can sync multiple folders and share with multiple users. Users can find the desktop app installation link by logging into ReadyCLOUD.netgear.com
- ReadyNAS Remote app for Windows and Mac has been replaced by ReadyCLOUD desktop app. The new desktop apps support advanced syncing as well as backing up content from a PC to a ReadyNAS.
- Share files with users by sending an email link. Users that receive the email will download the file directly from ReadyNAS. Security permissions are configurable.
- Support bitrot data protection. Automatically detect and correct corruption due to media degradation. Enabled per Share.
- Time Machine functionality has been improved to better manage multiple users. Each user will receive a private virtual Time Machine target. Capacity quota can be set for each user
- genie Marketplace has been removed. Users will no longer be required to setup a genie account to download and install add-on applications. All add-on applications can be installed directly from the Available tab.
- Support for disk spin down added. Included in the new Power tab under System.
- Format USB drives from the GUI
- New default user profile. Setup default user settings for Home Folders, Private Time Machine, and Group membership which are applied automatically to new users (Home Folder applies to local, domain, and cloud users. Private Time Machine applies to local users only. Group Membership only works for local users).
- iTunes and DLNA have been implemented as protocols. Users can enable iTunes and DLNA for any share.
- Backup job workflow has been updated and included ability to browse local sources and destinations
- Support Home folder snapshots
- Local Admin GUI page supports HTTP as well as HTTPS
- Support static route configurations
- Schedule volume maintenance tasks such as Scrub, Defragment, Balance, and Disk Test
- ReadyNAS and ReadyCLOUD portal will attempt to connect over local area network (LAN) when possible. This will improve transfer speeds.
- New default settings based on ReadyNAS model Users will see the new default settings after a factory default or on units that shipped with 6.2.0.
| RN102 | RN104 | RN312 | RN314 | RN516 | RN716x | RN2120 | RN3220 | RN4220 | |
| HTTP administration | On | On | On | On | On | Off | Off | Off | Off |
| Daily snapshots on default shares | Off | Off | On | On | On | On | N/A* | N/A* | N/A* |
| Daily snapshots on new shares | Off | Off | On | On | On | On | Off | Off | Off |
| Bit rot protection | Off | Off | Off | Off | Off | Off | Off | Off | Off |
| Performance warning when bit rot protection enabled | Yes | Yes | No | No | No | No | Yes | No | No |
*No shares are created by default on RN2120, RN3220 & RN4220
Deployment Notes / Limitations:
- Wake on LAN (WOL) will not be supported on the ReadyNAS 4220 at this time using the 10GbE port. Use the 1GbE port for WOL.
- There is no error message presented in the local admin GUI when the USB key is missing from the system for encrypted volumes. The LCD display will present a message that the USB key is missing.
- If the USB key is missing for encrypted volumes, the user has to wait for a 10 minute timeout. After the timeout, the encrypted volume will appear as inactive in the local admin GUI.
- If a FLEX-RAID volume has be expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should first eject the drive in the local admin GUI before removing the USB device from the ReadyNAS to prevent errors on the file system of the USB device.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 102, 104, and 2120 only support volumes up to 16TB.
- ReadyNAS devices updated to ReadyNAS 6.2.0 or later cannot be downgraded to ReadyNAS 6.1.x or earlier.
ReadyNAS OS 6.1.9 Release Notes: (September 2014)
Enhancements & Bug Fixes:
- Updated kernel with various filesystem and iSCSI improvements
- Added support for Richcomm-based UPS devices
- Added DLNA support FLV file type
- Prevents issue with too many open file descriptors in few Active Directory environments
- Various security updates (OpenSSL, GNUTLS, kernel)
- Fixed periodic log truncation
- Added UI option to configure sync policy for iSCSI LUNs
- Disable deprecated SSLv2 for admin UI
- Avoid potential flash corruption on some desktop x86 models after update. Appears during factory default.
- Fixed defragment operation so it doesn’t try to defragment snapshot
Deployment Notes / Limitations:
- After deleting a volume and creating a new one the old volume may still show up until after a reboot.
- WOL will not be supported on 3220/4220 at this time for 10GbE. Use 1GbE port for WOL.
- Disk failure on the 3220 and 4220 will not show LED failure for the exact drive that has failed, use local web admin page for disk failure information.
- Deleting volume with ReadyNAS Vault enabled will show error. User must turn off vault first.
- Can't set up bond on interfaces that are not already connected.
- If the USB key is missing from the system for Encryption, there is no error message presented.
- If USB key is missing for encryption, the user has to wait on a 10 minute timeout. After that, the encrypted volume is displayed as inactive.
- If a Flex-RAID volume has been expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should follow the safe removal procedure of first unmounting before removing the USB device. If these steps are not followed then you may develop errors on the file system on the USB device.
- UPS may report incorrect status after reboot, it may send out a warning during this time. After sometime, the UPS will start reporting the correct information.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
- ReadyNAS 104, 104, and 2120 only support volumes up to 16TB.
ReadyNAS OS 6.1.8 Release Notes: (May 2014)
- Fixed Admin UI compatibility issue with Chrome browser version 34.
- Fixed for potential volume mounting issue after reboot.
- Fixed backup manager not aborting with out of space errors
ReadyNAS OS 6.1.7 Release Notes: (April 2014)
Enhancements & Bug Fixes:
- Fixed automated antivirus definition update process to prevent a condition which the definition updates do not occur until a system reboot.
- Added informative logs when failing to join an Active Directory (ADS) domain.
- Fixed backup job issue to improve support for SCO FTP servers.
- Fixed backup job issue when empty directories on FTP server could cause the following directory contents to be skipped.
- Fixed network setting error in UI when there are no DNS servers configured.
- Fixed defrag hangs with large, very fragmented files.
- Fixed iTunes video playback support.
- Applied various security updates.
- Supports DLNA/UPnP-AV searches issued by clients using the Grilo framework.
- Fixed DLNA video stuttering issue on Panasonic clients.
- Added system serial number to SNMP queries.
- Fixed possible large file transfer failure immediately after a reboot. Additional attempts would succeed.
- Fixed incremental backup when the job is configured to do a full backup every 2 weeks.
- Compression option can be enabled when creating a new shared folder.
Deployment Notes / Limitations:
- After deleting a volume and creating a new one the old volume may still show up until after a reboot.
- WOL will not be supported on 3220/4220 at this time for 10GbE. Use 1GbE port for WOL.
- Disk failure on the 3220 and 4220 will not show LED failure for the exact drive that has failed, use local web admin page for disk failure information.
- Deleting volume with ReadyNAS Vault enabled will show error. User must turn off vault first.
- Can't set up bond on interfaces that are not already connected.
- If the USB key is missing from the system for Encryption, there is no error message presented.
- If USB key is missing for encryption, the user has to wait on a 10 minute timeout. After that, the encrypted volume is displayed as inactive.
- If a Flex-RAID volume has been expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should follow the safe removal procedure of first unmounting before removing the USB device. If these steps are not followed then you may develop errors on the file system on the USB device.
- UPS may report incorrect status after reboot, it may send out a warning during this time. After sometime, the UPS will start reporting the correct information.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
ReadyNAS OS 6.1.6 Release Notes: (Feb 2014)
Enhancements & Bug Fixes:
- Fixes USB device detection with certain devices or multiple hot plugs.
- Updates a few components to address security vulnerabilities.
- Optimizes filesystem behavior to avoid occasional high I/O latency.
- Optimizes filesystem block allocator for efficiency in finding free spaces.
- Reduces disk readahead size for better random performance.
- Fixes Antivirus app errors after firmware upgrade.
- Fixes SMB home directory access from trusted domain users in ADS mode.
- Updates backup manager to improve CPU resource usage.
- Accepts keyword "AUTO" in NETBIOS domain name field to auto-discover the proper value when joining domain.
- Fixes rare case of disappearing single-character files/folders in Windows AD.
- Fixes potential RAID 6 superblock update issue.
- Fixes ReadyDLNA specification compliance issues.
- Fixes Web UI authentication with usernames containing "@".
- Fixes broken filesystem scrub progress calculation.
- Fixes possible crash during defrag of very large files in ReadyNAS 102, 104 and 2120.
- Fixes potential system hang during extreme iSCSI loads.
- Fixes access problem from Windows 8.1 clients using Microsoft accounts.
- Fixes power supply unit (PSU) status errors on RN3220 and RN4220.
ReadyNAS OS 6.1.5 Release Notes: (Dec 2013)
Enhancements & Bug Fixes:
- Improved Active Directory handling of slow/remote connections by adding an option to force authentication each time. The "Not sync ADS accounts to local DB" option should be used when each authentication is validated with the ADS server.
- Fixed system instability issue with Photos II image import.
- Fixed ReadyNAS 4220 power supply unit alarm.
- Compatibility improvements for Windows 8.1 Internet Explorer 11.
- Fixed smart snapshot automated data pruning issue which could cause devices to not shutdown properly.
- Fixed anti-virus engine to address out of memory error and issue preventing successful Windows backup.
- FTP permissions update. When new files or sub-folders are created over FTP, file or sub-folder permissions are set to the same settings as the share-folder permission.
- Fixed drag and drop file compatibility with Chrome.
- SMB security patches applied.
- Kernel patches applied.
- Improved performance with large volumes (Most likely seen on the ReadyNAS 104). A factory default is required to make the changes. Copy all data off the ReadyNAS, upgrade the firmware, factory default the unit, and copy all data back onto the device
.
Deployment Notes / Limitations:
- After deleting a volume and creating a new one the old volume may still show up until after a reboot.
- WOL will not be supported on 3220/4220 at this time for 10GbE. Use 1GbE port for WOL.
- Disk failure on the 3220 and 4220 will not show LED failure for the exact drive that has failed, use local web admin page for disk failure information.
- Deleting volume with ReadyNAS Vault enabled will show error. User must turn off vault first.
- Can't set up bond on interfaces that are not already connected.
- If the USB key is missing from the system for Encryption, there is no error message presented.
- If USB key is missing for encryption, the user has to wait on a 10 minute timeout. After that, the encrypted volume is displayed as inactive.
- If a Flex-RAID volume has been expanded, the volume cannot be switched back to X-RAID mode.
- If you wish to remove a USB storage device, you should follow the safe removal procedure of first unmounting before removing the USB device. If these steps are not followed then you may develop errors on the file system on the USB device.
- UPS may report incorrect status after reboot, it may send out a warning during this time. After sometime, the UPS will start reporting the correct information.
- ReadyNAS 102, 104, and 2120 only support creating iSCSI LUNs 8TB and smaller.
ReadyNAS OS 6.1.4 Release Notes: (Oct 2013)
Enhancements & Bug Fixes:
- Fixed an incompatibility issue with OS X 10.9 Mavericks Time Machine backups.
- Fixed issue with backup job source or destination field does not accept a fully qualified domain name (FQDN).
ReadyNAS OS 6.1.3 Release Notes: (Oct 2013)
Enhancements & Bug Fixes:
- Added option for USB eject after backup completion.
- Improved SMTP setting page.
- Improved TiVo setting page.
- Improved Network setting page.
- Fixed a display issue for EDA channels.
- Fixed a problem for USB using ext4.
- Fixed issue with ReadyCLOUD transfer file time out issue.
- Fixed issue that system display extra network adapter during DNS change.
ReadyNAS OS 6.1.2 Release Notes: (Sept 2013)
Bug Fixes:
- Fixed issue with CRC on RN2120.
- Fixed volume expansion on newly-installed systems.
- Fixed issue with backup jobs that contain whitespace or other special characters in the source path.
- Fixed home directory creation for domain users with spaces in their user name.
- Fixed NTP time syncing with Windows ADS servers.
- Fixed domain mode login issues on domains where we cannot setup a secure channel.
ReadyNAS OS 6.1.1 Release Notes: (August 2013 )
New Features and Enhancements:
- Thick LUN allocation is limited to 90% of available free capacity.
- Multiple vDEV (virtual device) expansion in FLEX-RAID mode.
- Webdav protocol.
- Volume based Encryption.
- Help button includes embedded how-to and informational videos.
- Email alarm setting enhancements.
- NFS setting enhancements, NFS v4 NFS domain support and NFS Async option.
- Home directory enhancements.
- ACL (access control list) security setting enhancements.
- Force FTPS option added.
- Restore or download previous versions of files.
- Cloud and Remote User management enhancements.
- ReadyCLOUD access permission enhancements.
- ReadyCLOUD new user invite with an email.
Bug Fixes:
- Fixed issue where shutdown times for 6 bay units was taking a couple of minutes.
- Fixed issue where scroll bar for logs window did not expand when windows size was enlarged.
- Fixed issue where hostname changes prevented service from being able to turn off after reboot.
- Fixed issue where remote subfolders where not getting saved.
- Fixed issue where user could not upload file with Internet Explorer 10.
- Fixed issue where files larger that 4GB could not be backed up from USB drive.
- Fixed issue where the everyone permission for http shares was not correct.
- Fixed issue where AFP was not showing via Bonjour.
- Fixed issue where ReadyDLNA would start after each reboot.
- Fixed issue where a 4.x drive was added to a 6.x system it would boot off of the 4.x. code.
- Fixed issue where logs could not be downloaded during a rebuild.
- Fixed bug where a after a volume delete drop box would still show old shares.
- Fixed issue where a user could have multiple flex raid volumes and the volume would be inactive on reboot if the volumes where degraded.
- Fixed issue where deleted backup jobs where not being shown in the logs.
- Fixed issue where when doing a defrag user would not get any info on whether it stopped or started.
- Fixed issue where cloud user would show in shares even though ReadyNAS never joined ReadyCLOUD.
- Fixed issue where Tivo would show null/empty for active path.
- Fixed issue with renaming share names over 25 characters.
- Better handling of USB 3.0 devices being hot plugged.
- Fixed issue where ADS groups where listed in reverse alphabetical order.
- Fixed issue with extend timer setting when restarting apache after app installation to prevent offline message.
- Fixed issue where device can't be removed from the cloud.
ReadyNAS OS 6.0.8 Release Notes: (June 2013)
New Features and Enhancements:
- Added Plex Media Server to ReadyNAS 102, 104, and 2120 platforms. Plex Media Server was already available on ReadyNAS 312, 314, 316, and 516.
- Added new Available Apps tabs for quicker installation of applications. Applications listed on this tab can be installed without a genie+ Marketplace account or login. Over 20 applications are now available on this tab.
- Added support for a new feature in RAIDar (4.3.8) that will allow RAIDar to format disks when adding previously used disks to the RAID array. Download the latest version of RAIDar to utilize this feature.
- Added ability to invite users and assign access control via ReadyCLOUD.
- Added the ability to upload multiple files and folders from local file system to ReadyCOUD browse page. Currently only Chrome supports uploading folders (by drag and drop). IE 9, IE10, Safari, and Firefox cannot upload a folder.
- Added the ability to upload multiple files and folders from the local file system to the local admin browser page. Currently only Chrome supports uploading folders (by drag and drop). IE 9, IE10, Safari, and Firefox cannot upload a folder.
- Added the ability to launch applications from the System Overview page. Only applications that have a Launch URL will be listed in the System Overview page.
Bug Fixes:
- Fixed an issue with file browsing in share recovery mode.
- Fixed an issue with Support Remote Access SSH incorrectly displays status when system rebooted.
- Fixed an issue with Plex Media Sever transcoders default folder may fill up the root partition while session is active.
- Fixed reporting schema on fan speed and power voltage to suppress unneeded warning messages.
- Fixed calculation limitation to ensure system clock accuracy.
Limitations & Known Issues:
- No AFP/FTP auto permissions set for new files and folders. Newly added files and folders only can be written by the owner, others only have read permission.
- Dropbox is not able to pull updated deleted data from the server.
- MAC OSX, file syncing to ReadyDROP folder sometimes may prematurely paused. Please restart syncing by toggling the "Pause Syncing" then "Resume Syncing" of the ReadyDROP folder located on MAC menu bar.
- Scheduled backup job may be skipped if the preceding backup job completion overlaps its start time.
- When genie+ Marketplace does not work as expected, please restart the genie+Marketplace services located on the System->Settings screen.
- Downgrading from 6.0.8 to previous versions is not allowed.
ReadyNAS OS 6.0.7 Release Notes: (June 2013)
Bug Fixes:
- Fixed an issue with CRC acceleration that may compromise file system integrity when under IO stress.
- Fixed an issue with voltage reading in hardware monitoring of the 300 series where it can be 3% over the actual value.
- Added improvements to Apps installation.
- Added improvements to volume management enabling user has more control when adding non-blank disk or replace disk in the raid array.
Limitations & Known Issues:
- Drag and drop in Browse page only support files, doesn't support folders yet.
- No AFP/FTP auto permissions set for new files and folders. Newly added files and folders only can be written by the owner, others only have read permission.
- Plex Media Server's default temp folder is installed in /temp should be changed to data volume manually.
- Dropbox service needs to be re-enabled and re-authorized after volume deletion.
- Users cannot change the genie+ marketplace account associated with the ReadyNAS after the initial genie+ marketplace. If you need to change genie+ marketplace accounts, please contact technical support at support.netgear.com
- Downgrading from 6.0.6 to previous versions is not allowed.
ReadyNAS OS 6.0.6 Release Notes: (May 2013)
Bug Fixes:
- Fixed for HTTPS port conflict with other services (ReadyDLNA, NFS).
- Fixed an issue with volume deletion when Vault and DLNA services are active.
- Fixed an issue with ReadyDLNA TiVo setting options.
- Fixed an issue that may prolonged system reboot time.
Limitations & Known Issues:
- Drag and drop in Browse page only support files, doesn't support folders yet.
- No AFP/FTP auto permissions set for new files and folders. Newly added files and folders only can be written by the owner, others only have read permission.
- Plex Media Server's default temp folder is installed in /temp should be changed to data volume manually.
- Dropbox service needs to be re-enabled and re-authorized after volume deletion.
- Users cannot change the genie+ marketplace account associated with the ReadyNAS after the initial genie+ marketplace. If you need to change genie+ marketplace accounts, please contact technical support at support.netgear.com
- Downgrading from 6.0.6 to previous versions is not allowed.
ReadyNAS OS 6.0.4 Release Notes: (Feb 2013)
Bug Fixes:
- Fix issue with Available Apps not appearing for new registrations.
Limitations & Known Issues:
- Disk encryption is not supported in this release.
- The 6-bay products refer to a "backup button" on the device. The button is labeled "Ok".
- WebDAV is not supported in this release.
- ReadyNAS 2120 browser display needs to be wider than 1024 pixels to display properly
ReadyNAS OS 6.0.3 Release Notes: (Feb 2013)
NETGEAR is pleased to announce the release of ReadyNAS OS 6.0.3, the latest firmware for the following ReadyNAS network attached storage products:
- ReadyNAS 102
- ReadyNAS 104
- ReadyNAS 312
- ReadyNAS 314
- ReadyNAS 316
- ReadyNAS 516
- ReadyNAS 2120
The following are changes since ReadyNAS OS 6.0.1:
New features and enhancements
- Supports ReadyNAS 2120
Bug Fixes:
- Fixed volume scan issue for ReadyNAS Vault.
- Now able to remove apps that fail to install properly.
- UPS support for forced system shutdown.
- Added support for 6-bay touchpad.
- Fix for backup configurations.
- ReadyDROP share created by default.
- LCD messages include support for UPS messages.
- Fix for fan issue on RN516.
- Fix for UPNP.
- Fix for Wake-on-LAN.
- Fix for AFP going offline during share creation.
- Improve service handling when volume is deleted.
- Fixed continuous loop for usage with cloud user.
- Fix for eSATA.
- Add additional menu options for 6-bay touchpad.
- Fixed issue with ReadyCLOUD and device info.
- Fix for degraded volumes.
- Fix for NTP issue after reboots.
- Set maximum attempts when device cannot connect to ReadyCLOUD to 10.
- User no longer needs to authenticate ReadyCLOUD access if already logged in.
- Fixed disk channel display show zero.
- Added checks for bonded network interfaces.
- Fixed unallocated buffer access.
- Fix when trying to create two of the same shares.
- Fix in backup jobs to when ownership is reset.
- Fixed issue with Share name length.
- Fix for issue when web server (Apache) can't be started correctly.
- Fixed issue for ReadyCLOUD default share permissions.
- Added genie App warning message.
Limitations & Known Issues:
- Disk encryption is not supported in this release.
- The 6-bay products refer to a "backup button" on the device. The button is labeled "Ok".
ReadyNAS OS 6.0.2 Release Notes: (Jan 2013)
Bug Fixes:
- Fixed volume scan issue for ReadyNAS Vault.
- Now able to remove apps that fail to install properly.
- UPS support for forced system shutdown.
- Added support for 6-bay touchpad.
- Fix for backup configurations.
- ReadyDROP share created by default.
- LCD messages include support for UPS messages.
- Fix for fan issue on RN516.
- Fix for UPNP.
- Fix for Wake-on-LAN.
- Fix for AFP going offline during share creation.
- Improve service handling when volume is deleted.
- Fixed continuous loop for usage with cloud user.
- Fix for eSATA.
- Add additional menu options for 6-bay touchpad.
- Fixed issue with ReadyCLOUD and device info.
- Fix for degraded volumes.
- Fix for NTP issue after reboots.
- Set maximum attempts when device cannot connect to ReadyCLOUD to 10.
- User no longer needs to authenticate ReadyCLOUD access if already logged in.
- Fixed disk channel display show zero.
- Added checks for bonded network interfaces.
- Fixed unallocated buffer access.
- Fix when trying to create two of the same shares.
- Fix in backup jobs to when ownership is reset.
- Fixed issue with Share name length.
- Fix for issue when web server (Apache) can't be started correctly.
- Fixed issue for ReadyCLOUD default share permissions.
- Added genie App warning message.
Limitations & Known Issues:
- Disk encryption is not supported in this release.
- The 6-bay products refer to a "backup button" on the device. The button is labeled "Ok".
ReadyNAS OS 6.0.1 Release Notes: (Jan 2013)
Notes:
- This is the bug fix release of software for the new ReadyNAS 100-300-500 Series products.
- This software is not compatible with ReadyNAS units running 4.1.x, 4.2.x, or 5.3.x software
Changes/enhancements since previous release:
- Fixed automatic snapshot for the default shares.
- Fixed auto permission issue for shared folders.
- Disabled Flex RAID "Add Parity" functions if smaller size disk is selected and is used for adding parity.
- Reduced log size to prevent root partition becomes full.
- Fixed backup Vault share name are not found in option "Includes" and "Excludes" issue.
- Fixed UI crash caused by USB device eject.
- Fixed IE10 compatibility issue.
- Previous Version properly displays snapshot versions in Windows.