There are certain restrictions with file and folder names when using Windows. It is important to understand these restrictions if you transfer data between different operating systems.
Sometimes when transferring data between a NAS and a Windows server with a backup job, an error can occur when it reaches these restrictions.
If your files or folders have the following names, the data might not transfer to Windows:
- CON
- PRN
- AUX
- CLOCK$ (NT and older)
- NUL
- COM1-9 (example: COM1 or COM2)
- LPT1-9 (example: LTP1 or LTP2)
To work around this issue, you can try:
- Creating exclusions for those file or folder names on the backup job.
- Renaming the file over SMB before trying to include it in a transfer.
For more information about forbidden file and folder names on Windows, see http://blog.onetechnical.com/2006/11/16/forbidden-file-and-folder-names-on-windows/ or Microsoft Support.