Bug Fixes:
- Fixed the issue with POP3s and SMTPS: cannot send/receive mails.
- Fixed the issue that if SMTP filter is active, the UTM150 stops microsoft mails such as hotmail.es, hotmail.com, outlook.es, outlook.com. Emails come through only if SMTP filter is disabled.
- Fixed the GUI issue: Application Security > SSL Settings > SSL Settings, when "Allow the device to handle SSL connections using SSLv2" or "Allow the device to handle SSL connections using SSLv3" are checked and the settings applied, the check marks disappears soon (within a minute) after the "Operation Succeeded" message appears.
- Fixed the issue: Observed Ping loss (13-20%) over SSL-VPN tunnel while downloading the 2GB files over SSL-VPN tunnel.
- Fixed the issue: Unable to run FTP traffic from terminal and for HTTP only able to run from IE over SSL-VPN tunnels established in from IE11 Windows 8.1 32bit.
- Fixed the issue: Unable to run traffic over SSL-VPN Split tunnel established in WIN8.1(32bit and 64bit) OS IE11 browser.
- Fixed the issue that UTM is not keeping the service selected during the creation of the 13th inbound rule.
- Fixed the issue where it receives error about weak ephemeral Diffie-Hellman public key. Server has a weak ephemeral Diffie-Hellman public key,when visiting admin page or SSL page.
- Fixed the issue: IPSec pre-shared key gets replaced by asterisks causing the VPN connection to not going up after reboot.
- Fixed the service editing issue: when services numbers are added up to 127, editing one of the service will link to another one.
Known Issues and Limitations:
- Invalid MTU on WAN interface shouldn't be allowed.
- Maximum characters in fully qualified domain entry is not being deleted.
- Guest is able to establish/drop the IPSec VPN tunnel.
- Guest user was able to perform operations in wan status page.
- Help page needs to be updated in Policies page for "Related Policies Table".
- Guest is able to change the password after login from default portal link.
- Username with special characters cannot be deleted.
- Guest user are not able to log out after admin changes guest password.
- "Deny Login from WAN interface" option is unchecked for custom guest user in login policies page.
- DUT is not broadcasting its connected VLAN interface routes.
Using the Download Link below, download and extract the new firmware to a convenient place such as your desktop.
Download Links:
UTM5 / 10 /25: http://www.downloads.netgear.com/files/GDC/UTM10/UTM5_10_25-V3.6.2-4.zip
UTM50: http://www.downloads.netgear.com/files/GDC/UTM50/UTM50-V3.6.2-4.zip
UTM150: http://www.downloads.netgear.com/files/GDC/UTM150/UTM150-V3.6.2-4.zip
UTM 9S/25S: http://www.downloads.netgear.com/files/GDC/UTM9S/UTM25S_9S_U9S-Firmware-V3.6.2-4.zip