Enterprise AV Home WiFi Mobile Wifi Support Shop Deals

Symptom

  • Unable to add a ReadyNAS NFS share as NFS data store in VMware ESX
  • Unable to mount a ReadyNAS NFS share in VMware ESX
  • Attempting to mount or add a ReadyNAS NFS share in VMware ESX results in the following error message:
    • "Unable to mount file system.  The mount request was denied by NFS server."

Solutions

  1. Ensure that the NFS share is read/write enabled.
  2. When mounting the ReadyNAS NFS share in the VMware ESX server, the full path of the NFS share should be specified, i.e. /VolumeName/ShareName
    • Example:  If the ReadyNAS NFS share is named "datastore," then the full path is /data/datastore (default for ReadyNAS OS 6 systems), or, /c/datastore (default for legacy ReadyNAS systems).
Last Updated:07/07/2025 | Article ID: 13202

Our team is here to help!

Phone
Chat
Email