NETGEAR Insight Cloud Portal version 7.9
Version 7.9.3
Release Date:
December 24, 2025
New Features:
- Support for Adipsys External Captive Portals for Access Points
- Insight now supports Adipsys External Captive Portal integration for NETGEAR Insight-managed Pro WiFi networks, that enables enhanced hotspot and guest WiFi experiences. This feature is available for Pro WiFi 6 (WAX600 Series) and Pro WiFi 7 (WBE700 Series) access points. You can configure this feature at location or organization level WiFi networks.
- Guests are redirected to a custom-branded landing page and can authenticate using web-based or RADIUS-based login methods.
- Insight provides a customizable splash page and URL redirect, that gives more control over branding, access policies, and guest experience.
- Supported models:
- Pro WiFi 6: WAX610, WAX610Y, WAX620, WAX630, WAX630E, WAX615, WAX625, WAX628, WAX608Y, WAX638E, WAX618, WAX605, WAX610W, WAX333
- Pro WiFi 7: WBE710, WBE718, WBE750, WBE758
- Firmware requirements:
- WiFi 6 Access Points: Firmware 12.5.x.x and above
- WAX610W: Firmware 12.1.1.x and above
- WiFi 7 Access Points: Firmware 12.5.x.x and above
Note:The above firmware is not yet released.
Bug Fixes:
- Fixes the issue where the Insight iOS/Android App requires you to login intermittently.
- Fixes the issue where Insight Premium users can purchase less device credits than the number of device credits that are necessary to manage all devices.
- Fixes the issue where the organization level custom report does not display correctly when you view the report.
- Fixes the issue where you cannot see all locations when moving to next page when there are more than 50 locations under the organization.
- Fixes the issue where the Auto VoIP OUI based VLAN ID port status disables after the switch reboots when the Auto VoIP OUI based VLAN ID port status is enabled from the device UI of the switch. Note: Make sure any configuration done from device UI of M4250 and M4350 series fully managed switches should be saved using the save option available at the top right of the page.
- Fixes the issue where the Auto VoIP OUI based VLAN ID port status disables after modifying the existing Voice VLAN configuration from Location > Wired > Settings > VLAN > Edit Voice VLAN page and Location > Settings > VLAN/Network Setup page from Insight Web portal when the Auto VoIP OUI based VLAN ID port status is enabled from the device UI of the switch. Note: Make sure any configuration done from device UI of M4250 and M4350 series fully managed switches should be saved using the save option available at the top right of the page.
- Fixes the issue where the channels configured under the Manage RF profile do not push to access points (Location > Wireless > Settings > Manage Profiles > Edit RF profiles > Instant WiFi Preferred channel).
- Fixes the issue where the configured SSID does not display when the SXR30 Orbi device is operating in AP mode. (Location > Devices > Edit SXR30 > Wireless > Settings > WiFi and Captive Portal).
- Fixes the issue where the VLAN name configured in the VLAN page (Location > Wired > VLAN) displays incorrectly in the WiFi and Captive Portal page (Location > Wireless > Settings > WiFi and Captive Portal).
- Fixes the issue where the notification "This device has not reported monitoring data for more than [X] hours [X] minutes" displays under the Notifications > Critical section page for the access points added under the location.
Known Issues:
- The IPSec Site-to-Site Wizard supports adding a spoke router only at the group creation level, and you cannot edit the configuration.
- Android 4.4 and older versions are not supported.
- iOS 15 and older versions are not supported.
- NAT Mode SSID configuration is disabled for the WAX600 Series and WBE700 Series access points for locations where the wireless region is configured as India on Location level and Organization level WiFi networks (SSIDs).
- The number of connected WiFi clients does not display under the Orbi Pro satellite details on the Topology page (Location > Topology).
- An Orbi Pro satellite does not display in the SSID view on the Topology page (Location > Topology).
- The PoE source does not display for WAC505 or WAC510 access points on the Topology page (Location > Topology).
- When a WAC510 access point is connected to a switch, the Topology page does not display this (Location > Topology).
- The link speed does not display for the connection between WiFi clients and access points or Orbi Pro devices on the Topology page (Location > Topology).
- The link speed and usage do not display between a BR500 router and a switch on the Topology page (Location > Topology).
- “Management mode changed to Standalone” notifications are sent intermittently for an Insight-managed access point when you reset the device from the Insight app or Insight Cloud portal.
- The Instant Captive Portal feature does not work for clients connected to an OWE (Opportunistic Wireless Encryption) SSID on a newly onboarded access point.
Workaround: Reapply the Instant Captive Portal configuration from Insight. - On an Orbi Pro device that is running firmware version 2.5.2.104 or an earlier version, you cannot log in using the Insight app when the mobile device is connected to an Orbi Pro device during initial setup stage.
Workaround: Update the Orbi Pro device to the latest firmware. - It is not possible to revoke the Auto-reclaim feature after a factory reset on the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- Instant Captive Portal redirection fails when the SSID name includes the # special character.
Workaround: Rename the SSID so that it does not contain the # character. - On a WAC505, WAC510, WAC540, or WAC564 access point that runs a firmware version earlier than version 9.0.0.21, Instant Captive Portal redirection displays an error message when the fifth SSID is configured with the Instant Captive Portal.
Workaround: Edit the fifth SSID without modifying any settings and save the configuration. - When you edit the SSID of an Instant Captive Portal to which one or more clients are connected, the Insight Cloud Portal displays the following error message: “Fail to upload display ad.”
Workaround: Edit the SSID when no clients are connected to the captive portal. - The IPSec tunnel name does not display in the Tunnel Up or Tunnel Down notifications.
- The IP address for a connected neighbor device does not display correctly for the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- The Insight Cloud Portal does not refresh when you edit an IPSec policy name. This causes stale entries, such as Deleting policy and Creating policy, to display for 5 to 8 seconds.
Workaround: Refresh the web browser. - Incorrect error messages display in the Insight Cloud Portal when you try to add a new IPSec policy. This occurs if you previously set the maximum number of policies through the device UI.
- On a PR60X or PR460X router with dual WAN and WAN1 port as the active port, if you set up an IPSec site-to-site configuration, the local WAN IP address is blank.
Application Update Instructions:
To update the firmware of your product, log into Insight Cloud Portal https://insight.netgear.com or Insight mobile app, go to the Firmware page to upgrade the device firmware.
Version 7.9.4
Bug Fixes:
- Various bug fixes.
Known Issues:
- The IPSec Site-to-Site Wizard supports adding a spoke router only at the group creation level, and you cannot edit the configuration.
- Android 4.4 and older versions are not supported.
- iOS 15 and older versions are not supported.
- NAT Mode SSID configuration is disabled for the WAX600 series and WBE700 series access points for locations where the wireless region is configured as India on Location level and Organization level WiFi networks (SSIDs).
- The number of connected WiFi clients does not display under the Orbi Pro satellite details on the Topology page (Location > Topology).
- An Orbi Pro satellite does not display in the SSID view on the Topology page (Location > Topology).
- The PoE source does not display for WAC505 or WAC510 access points on the Topology page (Location > Topology).
- When a WAC510 access point is connected to a switch, the Topology page does not display this (Location > Topology).
- The link speed does not display for the connection between WiFi clients and access points or Orbi Pro devices on the Topology page (Location > Topology).
- The link speed and usage do not display between a BR500 router and a switch on the Topology page (Location > Topology).
- “Management mode changed to Standalone” notifications are sent intermittently for an Insight-managed access point when you reset the device from the Insight app or Insight Cloud portal.
- The Instant Captive Portal feature does not work for clients connected to an OWE (Opportunistic Wireless Encryption) SSID on a newly onboarded access point.
Workaround: Reapply the Instant Captive Portal configuration from Insight. - On an Orbi Pro device that is running firmware version 2.5.2.104 or an earlier version, you cannot log in using the Insight app when the mobile device is connected to an Orbi Pro device during initial setup stage.
Workaround: Update the Orbi Pro device to the latest firmware. - It is not possible to revoke the Auto-reclaim feature after a factory reset on the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- Instant Captive Portal redirection fails when the SSID name includes the # special character.
Workaround: Rename the SSID so that it does not contain the # character. - On a WAC505, WAC510, WAC540, or WAC564 access point that runs a firmware version earlier than version 9.0.0.21, Instant Captive Portal redirection displays an error message when the fifth SSID is configured with the Instant Captive Portal.
Workaround: Edit the fifth SSID without modifying any settings and save the configuration. - When you edit the SSID of an Instant Captive Portal to which one or more clients are connected, the Insight Cloud Portal displays the following error message: “Fail to upload display ad.”
Workaround: Edit the SSID when no clients are connected to the captive portal. - The IPSec tunnel name does not display in the Tunnel Up or Tunnel Down notifications.
- The IP address for a connected neighbor device does not display correctly for the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- The Insight Cloud Portal does not refresh when you edit an IPSec policy name. This causes stale entries, such as Deleting policy and Creating policy, to display for 5 to 8 seconds.
Workaround:Refresh the web browser. - Incorrect error messages display in the Insight Cloud Portal when you try to add a new IPSec policy. This occurs if you previously set the maximum number of policies through the device UI.
- On a PR60X or PR460X router with dual WAN and WAN1 port as the active port, if you set up an IPSec site-to-site configuration, the local WAN IP address is blank.
Application Update Instructions:
Make sure to update your Insight-supported devices to the latest firmware.
To update the firmware of your product, log into Insight Cloud Portal https://insight.netgear.com or Insight mobile app, go to the Firmware page to upgrade the device firmware.
Version 7.9.6
Release Date: March 10, 2026
Enhancements:
-
Addition of the "Enhanced Chat Support" to improve the support experience.
Bug Fixes:
- Fixes the issue where devices intermittently fail to display during local network discovery.
- General bug fixes and performance improvements.
Known Issues:
- The IPSec Site-to-Site Wizard supports adding a spoke router only at the group creation level, and you cannot edit the configuration.
- Android 4.4 and older versions are not supported.
- iOS 15 and older versions are not supported.
- NAT Mode SSID configuration is disabled for the WAX600 series and WBE700 series access points for locations where the wireless region is configured as India on Location level and Organization level WiFi networks (SSIDs).
- The number of connected WiFi clients does not display under the Orbi Pro satellite details on the Topology page (Location > Topology).
- An Orbi Pro satellite does not display in the SSID view on the Topology page (Location > Topology).
- The PoE source does not display for WAC505 or WAC510 access points on the Topology page (Location > Topology).
- When a WAC510 access point is connected to a switch, the Topology page does not display this (Location > Topology).
- The link speed does not display for the connection between WiFi clients and access points or Orbi Pro devices on the Topology page (Location > Topology).
- The link speed and usage do not display between a BR500 router and a switch on the Topology page (Location > Topology).
- “Management mode changed to Standalone” notifications are sent intermittently for an Insight-managed access point when you reset the device from the Insight app or Insight Cloud portal.
- The Instant Captive Portal feature does not work for clients connected to an OWE (Opportunistic Wireless Encryption) SSID on a newly onboarded access point.
Workaround: Reapply the Instant Captive Portal configuration from Insight. - On an Orbi Pro device that is running firmware version 2.5.2.104 or an earlier version, you cannot log in using the Insight app when the mobile device is connected to an Orbi Pro device during initial setup stage.
Workaround: Update the Orbi Pro device to the latest firmware. - It is not possible to revoke the Auto-reclaim feature after a factory reset on the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- Instant Captive Portal redirection fails when the SSID name includes the # special character.
Workaround: Rename the SSID so that it does not contain the # character. - On a WAC505, WAC510, WAC540, or WAC564 access point that runs a firmware version earlier than version 9.0.0.21, Instant Captive Portal redirection displays an error message when the fifth SSID is configured with the Instant Captive Portal.
Workaround: Edit the fifth SSID without modifying any settings and save the configuration. - When you edit the SSID of an Instant Captive Portal to which one or more clients are connected, the Insight Cloud Portal displays the following error message: “Fail to upload display ad.”
Workaround: Edit the SSID when no clients are connected to the captive portal. - The IPSec tunnel name does not display in the Tunnel Up or Tunnel Down notifications.
- The IP address for a connected neighbor device does not display correctly for the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- The Insight Cloud Portal does not refresh when you edit an IPSec policy name. This causes stale entries, such as Deleting policy and Creating policy, to display for 5 to 8 seconds.
Workaround: Refresh the web browser. - Incorrect error messages display in the Insight Cloud Portal when you try to add a new IPSec policy. This occurs if you previously set the maximum number of policies through the device UI.
- On a PR60X or PR460X router with dual WAN and WAN1 port as the active port, if you set up an IPSec site-to-site configuration, the local WAN IP address is blank.
Application Update Instructions:
Make sure to update your Insight-supported devices to the latest firmware.
To update the firmware of your product, log into Insight Cloud Portal https://insight.netgear.com or Insight mobile app, go to the Firmware page to upgrade the device firmware.
Version 7.9.7
Release Date: March 20, 2026
Bug Fixes:
-
General bug fixes and performance improvements.
Known Issues:
- The IPSec Site-to-Site Wizard supports adding a spoke router only at the group creation level, and you cannot edit the configuration.
- Android 4.4 and older versions are not supported.
- iOS 15 and older versions are not supported.
- NAT Mode SSID configuration is disabled for the WAX600 series and WBE700 series access points for locations where the wireless region is configured as India on Location level and Organization level WiFi networks (SSIDs).
- The number of connected WiFi clients does not display under the Orbi Pro satellite details on the Topology page (Location > Topology).
- An Orbi Pro satellite does not display in the SSID view on the Topology page (Location > Topology).
- The PoE source does not display for WAC505 or WAC510 access points on the Topology page (Location > Topology).
- When a WAC510 access point is connected to a switch, the Topology page does not display this (Location > Topology).
- The link speed does not display for the connection between WiFi clients and access points or Orbi Pro devices on the Topology page (Location > Topology).
- The link speed and usage do not display between a BR500 router and a switch on the Topology page (Location > Topology).
- “Management mode changed to Standalone” notifications are sent intermittently for an Insight-managed access point when you reset the device from the Insight app or Insight Cloud portal.
- The Instant Captive Portal feature does not work for clients connected to an OWE (Opportunistic Wireless Encryption) SSID on a newly onboarded access point.
Workaround: Reapply the Instant Captive Portal configuration from Insight. - On an Orbi Pro device that is running firmware version 2.5.2.104 or an earlier version, you cannot log in using the Insight app when the mobile device is connected to an Orbi Pro device during initial setup stage.
Workaround: Update the Orbi Pro device to the latest firmware. - It is not possible to revoke the Auto-reclaim feature after a factory reset on the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- Instant Captive Portal redirection fails when the SSID name includes the # special character.
Workaround: Rename the SSID so that it does not contain the # character. - On a WAC505, WAC510, WAC540, or WAC564 access point that runs a firmware version earlier than version 9.0.0.21, Instant Captive Portal redirection displays an error message when the fifth SSID is configured with the Instant Captive Portal.
Workaround: Edit the fifth SSID without modifying any settings and save the configuration. - When you edit the SSID of an Instant Captive Portal to which one or more clients are connected, the Insight Cloud Portal displays the following error message: “Fail to upload display ad.”
Workaround: Edit the SSID when no clients are connected to the captive portal. - The IPSec tunnel name does not display in the Tunnel Up or Tunnel Down notifications.
- The IP address for a connected neighbor device does not display correctly for the following switch models: GC110, GC110P, GC510P, GC510PP, GC728X, GC728XP, GC752X, and GC752XP.
- The Insight Cloud Portal does not refresh when you edit an IPSec policy name. This causes stale entries, such as Deleting policy and Creating policy, to display for 5 to 8 seconds.
Workaround: Refresh the web browser. - Incorrect error messages display in the Insight Cloud Portal when you try to add a new IPSec policy. This occurs if you previously set the maximum number of policies through the device UI.
- On a PR60X or PR460X router with dual WAN and WAN1 port as the active port, if you set up an IPSec site-to-site configuration, the local WAN IP address is blank.
Application Update Instructions:
Make sure to update your Insight-supported devices to the latest firmware.
To update the firmware of your product, log into Insight Cloud Portal https://insight.netgear.com or Insight mobile app, go to the Firmware page to upgrade the device firmware.